20TB+名家课程 提交需求

    通达信主战MACD指标公式

    分类:通达信公式 关注:1074 来源:股票资源网(Www.Gpzyw.Net) Tmie:2018/3/7 14:21:26


    DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26),LINETHICK2;

    DEA1:=EMA(DIF1,9),LINETHICK2;

    MACD1:=2*(DIF1-DEA1),STICK;

    MACD2:=EMA(MACD1,3);

    STICKLINE(MACD1<REF(MACD1,1)AND MACD1>0,0,MACD1,1,0),COLORGREEN;

    STICKLINE(MACD1>REF(MACD1,1)AND MACD1<0,0,MACD1,1,0),COLORYELLOW;

    STICKLINE(MACD1>REF(MACD1,1)AND MACD1>0,0,MACD1,1,0),COLORMAGENTA;

    STICKLINE(MACD1<REF(MACD1,1)AND MACD1<0,0,MACD1,1,0),COLORFFCC33;

    DIF:DIF1,COLOR33FF33;

    DEA:DEA1,COLORYELLOW;

    MACD:MACD1,NODRAW,COLORMAGENTA;

    低位金叉:CROSS(DIF1,DEA1) AND DIF1<-0.1;

    JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));

    二次金叉:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;

    STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

    DRAWICON(二次金叉,DEA1*0.9,1) ;

    {www.gpzyw.net 股票资源网_通达信股票指标公式}

    DRAWTEXT(二次金叉,0.4,' 二次金叉'),COLORYELLOW;

    强度:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK2;

    A1:=BARSLAST(REF(CROSS(DIF1,DEA1),1));

    底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF1>REF(DIF1,A1+1) AND CROSS(DIF1,DEA1);

    STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

    底背:DRAWLINE(A1=0,DEA1,底背离,DEA1,0),COLORRED,LINETHICK4;

    DRAWTEXT(底背离,0.1,' 底背离'),COLORYELLOW;

    A2:=BARSLAST(REF(CROSS(DEA1,DIF1),1));

    顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF1,A2+1)>DIF1 AND CROSS(DEA1,DIF1);

    顶背:DRAWLINE(A2=0,DEA1,顶背离,DEA1,0),COLORGREEN,LINETHICK4;

    DRAWTEXT(顶背离,0.1,'顶背离'),COLORGREEN;

    {OBV判势}

    OBV:=DIF;

    P:=5;

    AA1:=REF(OBV,P)=HHV(OBV,2*P+1);

    B1:=FILTER(AA1,P);

    C1:=BACKSET(B1,P+1);

    D1:=FILTER(C1,P);{高点}

    AA2:=REF(OBV,P)=LLV(OBV,2*P+1);

    B2:=FILTER(AA2,P);

    C2:=BACKSET(B2,P+1);

    D2:=FILTER(C2,P);{低点}

    上:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;

    下:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;

    向上:CROSS(OBV,上*1.01),NODRAW;

    相对能量:(OBV-下)/(上-下)*100,COLORYELLOW,NODRAW;

    R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);

    S11:=R11>REF(R11,1);

    DRAWLINE(D1,OBV,S11,OBV,1),COLORYELLOW;

    T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);

    U11:=T11>REF(T11,1);

    DRAWLINE(D2,OBV,U11,OBV,1),COLOR00FF00;

    STICKLINE(C>0,下,下,1,0),COLOR00FF00;

    STICKLINE(C>0,上,上,1,0),COLORFF00FF;

    DRAWTEXT(CROSS(OBV,上*1.01),上,'上'),COLORYELLOW;

    DRAWTEXT(CROSS(下*0.99,OBV),下,'下'),COLORYELLOW;



     


    股票资源网
    股票资源网
    股票资源网