20TB+名家课程 提交需求

    通达信股海聚宝指标公式

    分类:通达信公式 关注:1088 来源:股票资源网(Www.Gpzyw.Net) Tmie:2018/3/7 14:21:40


    VAR1:=REF(CLOSE,3.5);

    VAR2:=REF(CLOSE,1);

    VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;

    Q2:=(CLOSE-LLV(LOW, 21))/(HHV(HIGH, 21)-LLV(LOW, 21))*100;

    Q3:=SMA(Q2, 9, 1);

    Q4:=SMA(Q3, 3, 1);

    Q8:=HHVBARS(HIGH, 50);

    Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;

    快线:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORFFAA66;

    慢线:=EMA(Q3, 3),COLORRED;

    A:=VOL*CLOSE;

    B:=SUM(A,3.52)/SUM(VOL,3.82);

    B1:=EMA(B,13);

    主力线:=(B-B1)*191/B+50,COLORMAGENTA;

    多头:3*Q3-2*Q4,COLORYELLOW;

    VAR12:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

    空头:=SMA(VAR12,3,1),COLORGREEN;

    DRAWTEXT(CROSS(慢线, 多头) AND REF(多头,1)>80, 80, '*顶'),COLORRED,LINETHICK5;

    ●关注: DRAWTEXT(REF(CROSS(空头,慢线),25) AND 空头>1.005*慢线,60,'●关注'),COLORRED,LINETHICK1;

    ★关注: DRAWTEXT(REF(CROSS(慢线,多头),82) AND 慢线>1.3*多头,35,'★关注'),LINETHICK1;

    ★追涨: DRAWTEXT(REF(CROSS(多头,慢线),1) AND 多头>1.3*慢线,35,'★追涨'),COLORRED,LINETHICK1;

    ★抄底:IF(CROSS(多头,慢线) AND 快线>=REF(快线,1) AND 多头>=REF(多头,1)

    AND 慢线<38.2 AND 慢线>=REF(慢线,1) AND COUNT(REF(快线,1)<REF(快线,2) OR REF(慢线,1)<REF(慢线,2) OR REF(多头,1)<REF(多头,2),3)>=2,30,0),COLORMAGENTA;

    DRAWTEXT(CROSS(多头, 8) AND Q10<-13,20,'*大底'),COLORYELLOW,LINETHICK5;

    ★逃亡:=IF(快线< REF(快线,1) AND 快线>61.8,70,100),COLORBLUE;

    50,POINTDOT,COLORWHITE;

    AZ1:=AMOUNT/VOL/100;

    AZ2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

    AZ3:=SUM(AMOUNT,40)/AZ1/100;

    AZ4:=SUM(AMOUNT,80)/AZ1/100;

    BZ1:=DMA(AZ2,VOL/AZ3);

    BZ2:=DMA(AZ2,VOL/AZ4);

    BZ3:=(CLOSE-BZ1)/BZ1*100;

    BZ4:=(CLOSE-BZ2)/BZ2*100;

    {www.gpzyw.net 股票资源网_通达信股票指标公式}

    DRAWTEXT(ISLASTBAR AND C,93,' 股海聚宝,专用指标'),COLOR00AAFF;

    DRAWTEXT(ISLASTBAR AND C,80,' 黄柱出现,注意卖点'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,68,' 白柱出现,注意买点'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,56,' 顶和追涨,注意把握'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,44,' 选择正确,操作时段'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,32,' 按照图中,红绿转换'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,20,' 严格遵守,操作纪律'),COLOR00BBBB;

    DRAWTEXT(ISLASTBAR AND C,8,' 心态平衡,投资顺利'),COLOR00BBBB;

    AQ:=EMA(C,30);

    AQ1:=REF(AQ,5);

    STICKLINE(AQ<AQ1,45,53,0,0),COLORGREEN,LINETHICK2;

    STICKLINE(AQ>AQ1,45,53,0,0),COLORRED,LINETHICK2;

    OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

    RSV:=(OBV-LLV(OBV,34))/(HHV(OBV,34)-LLV(OBV,34))*100;

    K:=SMA(RSV,5,1);

    D:=SMA(K,3,1);

    JJ:=3*K-2*D;

    AA1:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100+50;

    AA2:=EMA(AA1,9);

    AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;

    AA4:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

    AA5:=SMA(AA4,13,8);

    OBV走势:=CEILING(SMA(AA5,13,8));

    AA6:=SMA(AA3,21,8);

    买观注:STICKLINE(OBV走势-AA6<-65,5,0,15,1);

    卖观注:STICKLINE(OBV走势-AA6>85,100,95,15,1);

    VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

    MAOBV:=SUM(VA,0);

    AD:=HHV(MAOBV,60);

    DRAWTEXT(MAOBV=HHV(MAOBV,60) AND C=HHV(C,0),2,'*');



     


    股票资源网
    股票资源网
    股票资源网