公式指标
公式指标

通达信精品控盘主图指标公式

分类:通达信公式 来源:股票资源网 关注:849 时间:2018-3-7 

周O1:=IF(WEEKDAY<REF(WEEKDAY,1),O,DRAWNULL);

周开:HHV(周O1,WEEKDAY)COLORRED,NODRAW;

周高:HHV(H,WEEKDAY)COLORYELLOW,NODRAW;

周低:LLV(L,WEEKDAY)COLOR32CD32,NODRAW;

周收:C#WEEK, COLORFF6EC7,NODRAW;

MC:=C#MONTH,NODRAW;

MO1:=IF(DAY<REF(DAY,1),O,DRAWNULL);

MO:=HHV(MO1,DAY),NODRAW;

STICKLINE(MC>=MO,MO,MC,4,-1)COLOR00009C;

STICKLINE(MC<MO,MO,MC,4,-1),COLOR4F2F4F;

STICKLINE(周收>=周开,周开,周收,4,0)COLOR00009C;

STICKLINE(周收<周开,周开,周收,4,0),COLOR9F3333;

MA5:MA(C,5);

MA10:MA(C,10);

MA20:MA(C,20);

MA40:MA(C,40);

MA60:MA(C,60);

STICKLINE(MA5>=MA60 AND MA60>=MA10,MA10,MA60,1,-1),COLORBLUE;

STICKLINE(MA5>=MA10 AND MA5<=MA60,MA10,MA5,1,-1),COLORBLUE;

STICKLINE(MA20>=MA60 AND MA60>=MA40,MA40,MA60,1,-1),COLORFF00FF;

STICKLINE(MA20>=MA40 AND MA20<MA60,MA40,MA20,1,-1),COLORFF00FF;

STICKLINE(MA5>=MA20 AND MA20>=MA10,MA10,MA20,1,-1),COLORYELLOW;

STICKLINE(MA5>=MA10 AND MA5<MA20,MA10,MA5,1,-1),COLORYELLOW;

上开:=O;

上收:=C;

上高:=H;

上低:=L;

JJ:=(上开+上高+上低)/3;

A:=EMA(JJ,4);

黄金线A:=A;

VA1:=EMA(上收,8);

VA2:=EMA(上收,20);

DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 黄金线A>REF(黄金线A,1),VA1*0.97,'B')COLORRED;

VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);

DRAWTEXT(VAR3P>90,LOW*0.978,'B')COLORMAGENTA;

DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'S')COLORGREEN;

VAR1:=EMA(EMA(CLOSE,13),13);

控盘:= (VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;

SS:=有庄控盘 AND CROSS(EMA(C,3),EMA(C,5)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018

OR CROSS(EMA(C,3),EMA(C,12)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018

OR CROSS(EMA(C,5),EMA(C,7)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018

OR CROSS(EMA(C,3),EMA(C,7)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(EMA(C,3),EMA(C,12));

DRAWICON(SS,LOW*0.978,36);

DRAWKLINE(H,O,L,C);

AAA:=CONST(HHV(H,90));

ABB:=MA(CLOSE,20);

ACC:=(CLOSE > MA(CLOSE,5));

ADD:=(MA(CLOSE,5) > MA(CLOSE,10));

AEE:=(CLOSE > MA(CLOSE,10));

AFF:=(MA(CLOSE,5) > MA(CLOSE,20));

AGG:=(CLOSE > MA(CLOSE,20));

AHH:=REF(ABB,1);

AII:=(ABB > AHH);

AVX:=(((((IF(ACC,10,(0 - 10)) + IF(ADD,10,(0 - 10))) + IF(AEE,10,(0 - 10)))

+ IF(AFF,10,(0 - 10))) + IF(AGG,10,(0 - 10))) + IF(AII,10,(0 - 10)));

DSLX:=(CLOSE / INDEXC);

DSLX1:=MA(DSLX,5);

DSLX2:=MA(DSLX,10);

V1:=MA(VOL,5);

V2:=MA(VOL,10);

T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));

T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));

T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));

T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));

T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));

T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));

T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));

T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));

T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));

T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));

T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));

T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));

T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));

T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));

T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));

{www.gpzyw.net 股票资源网_通达信股票指标公式}

DRAWTEXT(T1=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ;

DRAWTEXT(T2=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORRED ;

DRAWTEXT(T3=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORRED ;

DRAWTEXT(T4=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORRED ;

DRAWTEXT(T5=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'形态变坏,重仓者减持大半,清仓者观望'),COLORF0F000 ;

DRAWTEXT(T6=1 AND CURRBARSCOUNT=80,AAA*0.98 ,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORF0F000 ;

DRAWTEXT(T7=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股放量下跌,走势明显偏弱,离场观望'),COLORF0F000 ;

DRAWTEXT(T8=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股缩量下跌,走势偏弱,离场观望'),COLORF0F000 ;

DRAWTEXT(T9=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股形态良好,强势明显,量能充足,可以继续持有'),COLORRED ;

DRAWTEXT(T10=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORRED ;

DRAWTEXT(T11=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF99FF ;

DRAWTEXT(T12=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股走势趋弱,量能不足,减持大部分筹码'),COLOR008FFF ;

DRAWTEXT(T13=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORF0F000 ;

DRAWTEXT(T14=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORF0F000 ;

DRAWTEXT(T15=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORYELLOW ;

DRAWTEXT(T16=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'该股走势太弱,没有参与价值'),COLOR008FFF ;

DRAWTEXT(T17=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘理想,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ;

DRAWTEXT(T18=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORYELLOW ;

DRAWTEXT(T19=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ;

DRAWTEXT(T20=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘形态走坏,重仓者可以减去大部分仓位'),COLOR008FFF ;

DRAWTEXT(T21=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘缩量调整,注意风险,短线清仓观望'),COLOR008FFF ;

DRAWTEXT(T22=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘走势良好,量能理想,可以继续持有强势股'),COLORFF00FF ;

DRAWTEXT(T23=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘形态良好,但量能稍显不足,随时准备减仓'),COLORYELLOW ;

DRAWTEXT(T24=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘趋势不明,注意成交量变化,目前不适宜进场'),COLORF0F000 ;

DRAWTEXT(T25=1 AND CURRBARSCOUNT=80,AAA-(AAA*0.03),'大盘趋势向下,量能萎缩,不适合进场'),COLORF0F000 ;



 


  • 微信赞赏

    微信扫一扫,发红包:1-10元
    赞赏时请留言:您的QQ号,让我们记住您的支持
    支付宝赞赏

    支付宝扫一扫,转账支付:1-10元
    付款时填加备注:您的QQ号,让我们记住您的支持!
  • 喜欢就点击上面的赞赏按钮,给小编更新的动力!
    赞赏5元以上,免费远程安装公式

股友评价