20TB+名家课程 提交需求

    通达信顶底短牛指标公式

    分类:通达信公式 关注:2105 来源:股票资源网(Www.Gpzyw.Net) Tmie:2018/3/7 14:21:57


    N1:=5;N2:=10;

    LC:=REF(CLOSE,1);

    A0:=(2*C+H+L)/4;

    均线:=MA(A0,3)>REF(MA(A0,3),1);

    安全线:2,COLORRED,POINTDOT,LINETHICK4;

    VAR1:=C-REF(C,1);

    VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);

    MA5:=EMA(C,5);

    MA13:=EMA(C,13);

    UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS

    (MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS

    (MA5,MA13))+1),0),COLOR0000FF;

    DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS

    (MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS

    (MA13,MA5))+1),0),COLOR00FF00;

    BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND

    REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);

    底线:0,COLORFF00FF;

    顶线:10,COLORFF0000;

    STICKLINE(UP,0,0.2,3,0),COLOR0000FF;

    STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;

    STICKLINE(BT,0,3,2,0),COLOR000088;

    STICKLINE(BT,0,3,1,0),COLOR0000CC;

    STICKLINE(BT,0,3,0.22,0),COLOR0000FF;

    DRAWTEXT(BT,3,'短牛'),COLOR0000FF;

    {www.gpzyw.net 股票资源网_通达信股票指标公式}

    TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;

    STICKLINE(TJ1,0,2,3,0),COLOR880088;

    STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;

    STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;

    STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;

    DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;

    HR:=HHV(HIGH,55);

    HRY:=LLV(LOW,55);

    HRY11:=HR*HRY;

    HRY33:=SQRT(HRY11);

    TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;

    STICKLINE(TJ2,0,1,5,0),COLOR008888;

    STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;

    STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;

    STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;

    DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;

    ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);

    STICKLINE(ST,10,9,5,0),COLOR008800;

    STICKLINE(ST,10,9,2,0),COLOR00AA00;

    STICKLINE(ST,10,9,1,0),COLOR00CC00;

    STICKLINE(ST,10,9,0.2,0),COLOR00FF00;

    DRAWTEXT(ST,9,'卖'),COLOR00FF00;

    DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

    DEA:EMA(DIFF,9),COLORFFFF00;

    A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));

    底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);

    DRAWTEXT(底背离,-0.6,'底背离'),COLORWHITE;

    A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));

    顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);

    DRAWTEXT(顶背离,11,'顶背离'),COLORWHITE;



     


    股票资源网
    股票资源网
    股票资源网