20TB+名家课程 提交需求

    通达信二金MACD指标公式

    分类:通达信公式 关注:2185 来源:股票资源网(Www.Gpzyw.Net) Tmie:2018/3/7 14:21:58


    DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);

    DEA1:=EMA(DIF1,8);

    MACD1:=2*(DIF1-DEA1),STICK;

    MACD2:=EMA(MACD1,3);

    DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));

    STICKLINE(MACD1>MACD2 AND MACD1>0.1,0,MACD1,1,0),COLOR0000FF;

    STICKLINE(MACD2>MACD1 AND MACD2>0,0,MACD1,1,0),COLOR00FF88;

    STICKLINE(MACD1>REF(MACD2,1)AND MACD1,0,MACD2,1,0),COLORYELLOW;

    STICKLINE(MACD1>0,0,MACD2,1,0),COLOR00FFFF;

    STICKLINE(MACD1<0,0,MACD1,1,0),COLORGREEN;

    DIF:DIF1,COLORGREEN,LINETHICK1;

    DEA:DEA1,COLORYELLOW,LINETHICK1;

    MACD:MACD1,NODRAW,COLORMAGENTA;

    强:IF(DIF1>=DEA1,DIF1,DRAWNULL),COLORRED,LINETHICK1;

    弱:IF(DEA>=DIF1,DEA1,DRAWNULL),COLORGREEN,LINETHICK1;

    抄底:IF((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),0.15,(-0)),COLOR00FF00,LINETHICK1;

    中区:0,COLORYELLOW,LINETHICK1;

    动力:MA(MACD1,5),,COLORYELLOW,LINETHICK2;

    主动:IF(MACD>=动力 AND 动力<=中区,动力,DRAWNULL),COLORYELLOW,LINETHICK2;

    主拉:IF(动力>=中区,动力,DRAWNULL),COLORRED,LINETHICK2;

    翻空:IF(动力<中区 AND 动力>MACD,动力,DRAWNULL),COLORGREEN,LINETHICK2;

    {www.gpzyw.net 股票资源网_通达信股票指标公式}

    AA:=BARSLAST(REF(CROSS(DIF1,DEA1),1));

    BB:=REF(CLOSE,AA+1)>CLOSE AND DIF1>REF(DIF1,AA+1) AND CROSS(DIF1,DEA1);

    JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

    二金:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;

    DRAWICON(二金,DEA1*1.04,15) ;

    DRAWTEXT(二金,-0.25,' 2'),COLORFF00FF;

    VAR1:=EMA(CLOSE,12)-EMA(CLOSE,25);

    VAR2:=EMA(VAR1,3);

    VAR3:=VAR1>VAR2;

    VAR4:=VAR1<VAR2;

    STICKLINE(VAR3,VAR1,VAR2,1,0),COLORRED;

    STICKLINE(VAR4,VAR1,VAR2,1,0),COLORGREEN;



     


    股票资源网
    股票资源网
    股票资源网