20TB+名家课程 提交需求

    通达信号称百万主图指标公式

    分类:通达信公式 关注:439 来源:股票资源网(Www.Gpzyw.Net) Tmie:2018/6/7 16:28:02


    SAT:=IF(((((AMOUNT)/(CLOSE))/((HHV(AMOUNT,20))/(HHV(CLOSE,20))))*(100)>100),100,(((AMOUNT)/(CLOSE))/((HHV(AMOUNT,20))/(HHV(CLOSE,20))))*(100));

    AA10:MA(CLOSE,8),COLOR00FFFF;

    AA12:MA(CLOSE,12),COLOR00FFFF;

    BB10:=((ATAN(AA10-REF(AA10,1)))*(3.1416))*(10);

    BB12:=((ATAN(AA12-REF(AA12,1)))*(3.1416))*(10);

    MA13:=MA(CLOSE,13);

    X1:=(CLOSE+LOW+HIGH)/(3);

    BB13:=((ATAN(EMA(X1,13)-REF(EMA(X1,13),1)))*(3.1416))*(10);

    EMA8:=EMA(CLOSE,8);

    DRAWTEXT(FILTER((BB13>1) AND (EMA(X1,13)>REF(EMA(X1,8),1)),10),EMA8,'∠45上升'),COLORFFFFFF;

    压力:MA(REF(HHV(CLOSE,30),1),2),COLOR9DFFFF;

    支撑:MA(REF(LLV(CLOSE,30),1),2),COLORABFF46;

    AA1:=(AMOUNT)/(VOL);

    BB1:=(LOW<(AA1)*(0.9));

    CC1:=(((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100)>1.2);

    DD1:=(LOW<(MA(CLOSE,5))*(0.921));

    EE1:=(VOL<(MA(VOL,5))*(1.5));

    FF1:=BB1 AND CC1 AND DD1 AND EE1;

    DRAWTEXT(FF1,(LOW)*(0.96),'老鼠仓'),COLOR4080FF;

    A51:=(3)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1))-(2)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),5,1));

    黑马线:=EMA(A51,5);

    A54:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);

    趋势线:=MA((3)*(SMA(A54,6,1))-(2)*(SMA(SMA(A54,5,1),5,1)),2);

    DRAWTEXT(CROSS(趋势线,0) AND (黑马线<40),(LOW)*(0.96),'▲大黑马'),COLOR00FFFF;

    LC:=REF(CLOSE,1);

    RSI:=((SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1)))*(100);

    FF:=EMA(CLOSE,3);

    MA15:=EMA(CLOSE,21);

    DRAWTEXT(CROSS(FF,MA15),(LOW)*(0.96),'底背离'),COLORA6E500;

    DRAWTEXT(CROSS(88,RSI),(HIGH)*(1.04),'顶背离'),COLOR1880FF;

    VAR2:=LLV(LOW,27);

    VAR3:=HHV(HIGH,34);

    VAR4:=(EMA(((CLOSE-VAR2)/(VAR3-VAR2))*(4),4))*(25);

    注意买:=IF((VAR4<10),80,100);

    RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);

    K:=SMA(RSV,3,1);

    D:=SMA(K,3,1);

    J:=(3)*(K)-(2)*(D);

    超跌:=IF((J<0),10,0);

    BDDD:=(LLV(J,2)=LLV(J,8));

    买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND (J<20),30,0);

    DRAWTEXT(买入 AND (注意买=100) AND (超跌=0),(LOW)*(0.96),'短线'),COLOR8000FF;

    {www.gpzyw.net 股票资源网_最新股票指标公式}

    MTM:=CLOSE-REF(CLOSE,1);

    DX:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));

    买:=IF((LLV(DX,2)=LLV(DX,7)) AND COUNT((DX<0),2) AND CROSS(DX,MA(DX,2)),1,0);

    DRAWTEXT(FILTER((买=1),5),(LOW)*(0.96),'拉升'),COLORFFDE00;

    STICKLINE((CLOSE>REF(CLOSE,1)),HIGH,LOW,0,1),COLOR0000FF;

    STICKLINE((CLOSE>REF(CLOSE,1)),OPEN,CLOSE,8,0),COLOR000055 ;

    STICKLINE((CLOSE=REF(CLOSE,1)),HIGH,LOW,0,1),COLORFFFFFF;

    STICKLINE((CLOSE=REF(CLOSE,1)),OPEN,CLOSE,8,1),COLOR333333;

    STICKLINE((CLOSE<REF(CLOSE,1)),HIGH,LOW,0,1),COLORFFFF00;

    STICKLINE((CLOSE<REF(CLOSE,1)),OPEN,CLOSE,8,0),COLORFF0033;

    STICKLINE((CLOSE>OPEN),OPEN,LOW,0.5,0),COLOR0000FF;

    STICKLINE((CLOSE>OPEN),CLOSE,HIGH,0.5,0),COLOR0000FF;

    STICKLINE((OPEN>=CLOSE),CLOSE,LOW,0.5,0),COLOR00FF00;

    STICKLINE((OPEN>=CLOSE),OPEN,HIGH,0.5,0),COLOR00FF00;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,7,0),COLORFF7700;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,6,0),COLORFF9900;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,5,0),COLORFFBB00;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,4,0),COLORFFCC00;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,3,0),COLORFFDD00;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,2,0),COLORFFEE00;

    STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,1,0),COLORFFFF00;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,7,0),COLOR000055 ;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,6,0),COLOR000066 ;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,5,0),COLOR000077;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,4,0),COLOR000099 ;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,3,0),COLOR0000BB;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,2,0),COLOR0000DD;

    STICKLINE((CLOSE>OPEN),CLOSE,OPEN,1,0),COLOR0000FF;

    VAR9Q:=((((CLOSE=HHV(CLOSE,4)) AND ((REF(CLOSE,1)>=REF(CLOSE,2)) OR (REF(CLOSE,1)>=REF(CLOSE,3))) OR (REF(CLOSE,1)=HHV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,2))) OR (REF(CLOSE,2)=HHV(CLOSE,4)) AND (REF(CLOSE,3)=LLV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1))) OR (REF(CLOSE,3)=HHV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1)) AND (CLOSE>=REF(CLOSE,2)));

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),7,0),COLOR000055 ;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),6,0),COLOR000066;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),5,0),COLOR000077;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),4,0),COLOR000099 ;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),3,0),COLOR0000BB;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),2,0),COLOR0000DD;

    STICKLINE(VAR9Q,CLOSE,(OPEN+CLOSE)/(2),1,0),COLOR0000FF;

    VARAQ:=(CLOSE=HHV(CLOSE,4)) AND (REF(CLOSE,1)=LLV(CLOSE,4));

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),7,0),COLORFF11FF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),6,0),COLORFF33FF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),5,0),COLORFF55FF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),4,0),COLORFF77FF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),3,0),COLORFF99FF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),2,0),COLORFFBBFF;

    STICKLINE(VARAQ,CLOSE,(OPEN+CLOSE)/(2),1,0),COLORFFDDFF;

    VARCQ:=((REF(CLOSE,1)=LLV(CLOSE,4)) AND (CLOSE>=REF(CLOSE,2)) OR (REF(CLOSE,2)=LLV(CLOSE,4)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<REF(CLOSE,4)) AND (CLOSE>=REF(CLOSE,1)));

    STICKLINE(VARCQ,OPEN,(OPEN+CLOSE)/(2),7,0),COLOR003300;



     


    股票资源网
    股票资源网
    股票资源网