公式指标
公式指标

通达信自用抓牛股指标公式

分类:通达信公式 来源:股票资源网 关注:754 时间:2018-6-7 

{MACD}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:SMA(RSV,3,1),LINETHICK2,COLORWHITE;

D:SMA(K,3,1),LINETHICK2,COLOR00DDDD;

J:3*K-2*D,LINETHICK2,COLOR800080;

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK0,COLOR0099FF;

DEA :EMA(DIF,9),LINETHICK0,COLORD89837;

MACD:2*(DIF-DEA),COLORFF9999,LINETHICK0;

YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);

阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));

支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));

今压:REF(阻价,1),LINETHICK0,COLORAA11BB;

今撑:REF(支价,1),LINETHICK0,COLOR009900;

明压:阻价,LINETHICK0;

明撑:支价,LINETHICK0;

RSV1:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*101;

KK:=SMA(RSV1,3,1);

DD:=SMA(KK,3,1);

JJ:=3*KK-2*DD;

买卖:=IF(JJ>=100,100,IF(JJ<=0,0,JJ));

明天买:IF(买卖=100,0-10,0),COLOR00CCCC;

明天卖:IF(买卖=0,90,100),COLOR00FF00;

KX:=250;

KH:=HHV(K,KX);

DH:=HHV(D,KX);

JH:=HHV(J,KX);

KL:=LLV(K,KX);

DL:=LLV(D,KX);

JL:=LLV(J,KX);

HKMAX:=MAX(KH,MAX(DH,JH));

LKMIN:=MIN(KL,MIN(DL,JL));

KHLB:=(HKMAX+LKMIN)/2;

KHLC:=HKMAX-LKMIN;

MHF:=HHV(DIF,KX);

MHD:=HHV(DEA,KX);

MHM:=HHV(MACD,KX);

MLF:=LLV(DIF,KX);

MLD:=LLV(DEA,KX);

MLM:=LLV(MACD,KX);

HMAX:=MAX(MHF,MAX(MHD,MHM));

LMIN:=MIN(MLF,MIN(MLD,MLM));

FHLB:=(HMAX-LMIN)/100;

FHLC:=HMAX-LMIN;

SH:=(0-FHLB)*(KHLC/FHLC)+KHLB;

DIFA:=(DIF-FHLB)*(KHLC/FHLC)+KHLB;

DEAA:=(DEA-FHLB)*(KHLC/FHLC)+KHLB;

MACDA:=(MACD-FHLB)*(KHLC/FHLC)+KHLB;

CDA:=MACD<REF(MACD,1) AND MACD>0;

CDB:=MACD>=REF(MACD,1) AND MACD>0;

CDC:=MACD>REF(MACD,1) AND MACD<0;

CDD:=MACD<=REF(MACD,1) AND MACD<0;

STICKLINE(CDA,SH,MACDA,2,0),COLOR00AAFF;{黄色段}

STICKLINE(CDB,SH,MACDA,2,0),COLOR0000AA; {红色段}

STICKLINE(CDC,SH,MACDA,2,0),COLORAA00BB;{向上粉红}

TYP:=(HIGH+LOW+CLOSE)/3;

STICKLINE(DIF>REF(DIF,1),20,20,2,0),COLORRED;

STICKLINE(DIF<REF(DIF,1),20,20,2,0),COLORGREEN;

STICKLINE(K>=REF(K,1) OR K>D AND DIF>REF(DIF,1),80,80,2,1),COLORRED;

STICKLINE(K<REF(K,1),80,80,2,1),COLORGREEN;

MACD金叉:=CROSS(MACD,DIF) AND MACD>=(0-0.05) AND MACD<=0.02;

DRAWTEXT(MACD金叉,MACDA*0.82,'▲MACD金叉'),COLOR00FFFF;

XX:=EMA(MA(LOW,3)*0.96,30);

DIF金叉:=IF(CROSS(DIF,DEA) AND XX-REF(XX,1)>0 AND MACD>=REF(MACD,1) AND DIF<=0,1,0);

DRAWTEXT(DIF金叉=1,DIFA*1.68,'DIF金叉'),COLORCDFFBB;

低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

DRAWTEXT(低位金叉,DEAA*0.99,'▲DIF低位金叉'),COLOR0099DD;

DIFDEA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(DIFDEA=2,21)=1;

DRAWTEXT(二次金叉,DEAA*0.99-8,'▲DIF 二次金叉'),COLORFF00FF;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

DRAWTEXT(底背离,DEAA*0.99-16,'▲DIF底背离'),COLOR0099FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

DRAWTEXT(FILTER(顶背离,5),DEAA*1.02,'▲DIF顶背离'),COLORDDAAAA;

{周金叉,死叉}

周DIF:="MACD.DIF#WEEK";

周DEA:="MACD.DEA#WEEK";

周MACD:="MACD.MACD#WEEK";

DIF周金叉:=CROSS(周DIF,周DEA);

DRAWTEXT(DIF周金叉,DEAA,'DIF周金叉'),COLOR0099FF;

DRAWTEXT(CROSS(周DEA,周DIF),DEAA+4,'▲DIF周死叉'),COLORCDFFBB;

MACD周金叉:=CROSS(周MACD,周DIF) AND 周MACD>=(0-0.05) AND 周MACD<=0.02;

DRAWTEXT(MACD周金叉,MACDA-0.03,'▲MACD周金叉'),COLOR00FFFF;

{月金叉,死叉}

月DIF:="MACD.DIF#MONTH";

月DEA:="MACD.DEA#MONTH";

DIF月金叉:=CROSS(月DIF,月DEA);

DRAWTEXT(DIF月金叉,DEAA*0.98,'★DIF月金叉'),COLOR00FFCC;

DRAWTEXT(CROSS(月DEA,月DIF),DEAA*1.02,'★DIF月死叉');

周K:="KDJ.K#WEEK"(9,3,3);

周D:="KDJ.D#WEEK"(9,3,3);

周J:="KDJ.J#WEEK"(9,3,3);

月K:="KDJ.K#MONTH"(9,3,3);

月D:="KDJ.D#MONTH"(9,3,3);

月J:="KDJ.J#MONTH"(9,3,3);

月金叉:=CROSS(月K,月D);

周金叉:=CROSS(周K,周D);

日金叉:=FILTER(CROSS(K,D) AND K<20,4);

DRAWTEXT(月金叉,月D-2,'★'),COLOR0022EE;

DRAWTEXT(月金叉,月D-2,'.KD月金叉'),COLORYELLOW;

DRAWTEXT(周金叉,周D,'★'),COLOR0022EE;

DRAWTEXT(周金叉,周D,'. KD周金叉'),COLORGREEN;

DRAWICON(日金叉,K,1);

DRAWTEXT(日金叉,D-6,'★KD低位金叉'),COLOR00CCCC;

DRAWTEXT(CROSS(周D,周K),周D*1.2,'★KD周死叉'),COLOR00DDBB;

DRAWTEXT(CROSS(月D,月K),月D,'★KD月死叉'),COLORFFFFFF;

KDB:=BARSLAST(REF(CROSS(K,D),1));

KDDB:=REF(CLOSE,KDB+1)>CLOSE AND REF(K,KDB+1)<K AND CROSS(K,D);

K底背:=IF(FILTER(KDDB>0,5),1,0);

DRAWTEXT(K底背=1,D*0.98,'★KD底背离'),COLORDDDDDD;

KDD:=BARSLAST(REF(CROSS(D,K),1));

{www.gpzyw.net 股票资源网_最新股票指标公式}

K顶背:=REF(CLOSE,KDD+1)<CLOSE AND REF(K,KDD+1)>K AND CROSS(D,K);

DRAWTEXT(FILTER(K顶背>0,5),D+8,'★KD顶背离'),COLORFFAA22;

MD1:=MA(CLOSE,80)-MA(CLOSE,13)/3;

MD2:=MA((CLOSE-MD1)/MD1,3);

买点1:=CROSS(MD2,0) AND LOW/REF(HIGH,1)<1.012 AND J<75 AND J>REF(J,1);

MA12:=MA(CLOSE,12);

佳点:=IF(FILTER(MACD>=REF(MACD,5) AND OPEN<=REF(CLOSE,1) AND XX-REF(XX,1)>0 AND MACD<=0 AND MA12-REF(MA12,1)>=0,3) AND J<80 AND J>REF(J,1) AND D>REF(D,1) AND (DIF>=REF(DIF,1) OR DEA>=REF(DEA,1)),1,0);

DRAWTEXT(佳点=1,MACDA*0.98,'★佳点'),COLOR0099FF;

DX0:=EMA(CLOSE,2)-EMA(OPEN,5);

DX1:=IF(CROSS(DX0,MACD) AND LOW<=XX AND MACD<=(0-0.11) AND (J<20 OR K<20),1,0);

DRAWTEXT(FILTER(DX1,3),0,'★短10%'),COLOR00CC00;{短线}

MA10:=MA(CLOSE,10);

SS:=EMA(MA(HIGH,3)*1.05,30);

LQS:=IF(FILTER(0.7*(CROSS(DIF,DEA) AND CLOSE<SS AND XX-REF(XX,1)>0 AND CROSS(MACD,0) AND MACD>=0 AND DIF>0 AND MA10-REF(MA10,1)>0 AND VOL>REF(VOL,1))>=0.7 AND (CLOSE<SS AND XX-REF(XX,1)>0),5) AND J<80,1,0);

DRAWTEXT(LQS=1,MACDA*0.98,'★量价齐上'),COLORCDFFDD;{量价齐上}

最佳点:=IF(COUNT(MD2>REF(MD2,1),3)=3 AND COUNT(MD2<0,10)=10 AND REF(MD2,3)=LLV(MD2,10) AND J<80 AND J>REF(J,1),1,0);

DRAWTEXT(最佳点=1,J,'★最佳点'),COLORFF00CC;

买点2:=REF(MD2,2)=LLV(MD2,20) AND REF(MD2,2)<0.071 AND REF(MD2,2)<REF(MD2,1) AND

NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1) AND J<75 AND J>REF(J,1);

DRAWTEXT(买点1 OR 买点2,D-1,'买'),COLORFF00CC;

{预涨}

YZ:=(INTPART(SMA(RSV,3,1))+INTPART(SMA(K,3,1)))/2;

预涨:=CROSS(YZ,50) AND J<95 AND DIF>REF(DIF,1) AND LOW<REF(CLOSE,1);

DRAWTEXT(预涨,D*0.6,'★预涨'),COLORA52A2A;



 


  • 微信赞赏

    微信扫一扫,发红包:1-10元
    赞赏时请留言:您的QQ号,让我们记住您的支持
    支付宝赞赏

    支付宝扫一扫,转账支付:1-10元
    付款时填加备注:您的QQ号,让我们记住您的支持!
  • 喜欢就点击上面的赞赏按钮,给小编更新的动力!
    赞赏5元以上,免费远程安装公式

股友评价