公式指标
公式指标

同花顺趋势角度主图指标公式

分类:同花顺公式 来源:股票资源网 关注:1590 时间:2017-7-26 

//潜在高转送次新股:每股资本公积+每股未分配利润>5元,净资产收益率>10%,流通市值<50亿

流通股:SHGZG/10000/10000,coloryellow,NODRAW;

资本公积:GJJ/ZGB,colorgreen,NODRAW;

利润:WFPLR/ZGB,2,colormagenta,NODRAW;

净资产:MGJZC,2,colorff7f00,NODRAW;

角度:((ATAN((C - REF(C,1))) * 3.14159) * 10),colorcyan,NODRAW;

A1:=MAX(MAX(EMA(C,5),EMA(C,13)),MAX(EMA(C,34),EMA(C,55)));

A2:=MIN(MIN(EMA(C,5),EMA(C,13)),MIN(EMA(C,34),EMA(C,55)));

偏离度:A1-A2,color00aaff,NODRAW;

SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

AA10:MA(CLOSE,8),COLOR0000FF;

AA12:MA(CLOSE,12),colorcyan;

BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);

BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);

MA13:=MA(CLOSE,13);

STICKLINE((((AA12 <= AA10) AND (BB12 >= 1)) AND (BB10 >= 1)),AA10,AA12,4,0),COLOR0080FF;

STICKLINE((((AA12 >= AA10) AND (BB10 <= 1)) AND (BB10 <= 1)),AA10,AA12,4,0),COLOR00FF00;

X1:=(C+L+H)/3;

BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,'∠45上升'),colorwhite;

压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;

A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

黑马线:=EMA(A51,5);

A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

LC:=REF(CLOSE,1);

RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);

VAR2:=LLV(LOW,27);

VAR3:=HHV(HIGH,34);

VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

MTM:=C-REF(C,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

//五线刚走顺

MA5:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

MA60:=MA(C,60);

N:=(MA5>MA10 AND MA10>MA20 AND MA20>MA30 AND MA30>MA60) AND REF(MA5>MA10 AND MA10>MA20 AND MA20>MA30 AND MA30<MA60,1);

DRAWTEXT(N,MAX(AA10,AA12)*1.5,'五线'),colormagenta;

AA:=(C*2+H+L+O)/5;

A0:=MA(C,5);

A1:=(EMA(AA,4)+MA(AA,8)+MA(AA,16))/3,colorwhite;

A2:=(EMA(AA,9)+MA(AA,18)+MA(AA,36))/3,COLORFF00FF;

A3:=(EMA(AA,13)+MA(AA,26)+MA(AA,52))/3,COLOR00FF00;

A4:=(EMA(AA,24)+MA(AA,48)+MA(AA,96))/3,COLOR0000FF;

A5:=EMA(100*(C-LLV(L,100))/(HHV(H,100)-LLV(L,100)),5);

A6:=A5/4;

A7:=MAX(MAX(A1,A2),MAX(A3,A4));

A8:=MIN(MIN(A1,A2),MIN(A3,A4));

A9:=MIN(MIN(A1,A2),A3);

A10:=MAX(MAX(A1,A2),A3);

DRAWICON(A6>22.5 AND REF(A0,1)>REF(A0,2)AND A0<REF(A0,1),H+0.2,2);

DRAWICON(CROSS(A2,A4)AND A3>REF(A3,1)AND A0>REF(A0,2)AND (A1-A4)/A4<0.02,A2,1);

DRAWICON(CROSS(A1,A4)AND CROSS(A2,A3),A1,10);

DRAWTEXT(FILTER(H>A7 AND L<A8 AND A1>REF(A1,1)AND A2>REF(A2,1)AND A4>REF(A4,2)AND (A7-A8)/A8<0.04 AND C>O AND (H-C)/(C-O)<0.4,3),压力*1.05,'穿四线'),colorred;

DRAWTEXT(LONGCROSS(A1,A3,30)AND (A4-A3)/A3<0.05 AND A10<A4,压力*1.05,'圆弧底'),Color00aaff;

DRAWTEXT(LONGCROSS(A1,A2,15)AND CROSS(A2,A3),压力*1.05,'双交叉'),colormagenta;

DRAWTEXT((A1-A2)/A2>0.04 AND A2>A3 AND L>A1 AND O>C AND O=H,压力*1.05+0.2,'顶'),colorgreen;

DRAWTEXT(FILTER(A4>REF(A4,2)AND REF(A1,3)<REF(A3,3)AND C>O AND(A10-A9)/A9<0.005,5),压力*1.05,'三线粘合'),colorred;

//均线粘合突破选股公式

N:=35;

M:=50;

X1:=MIN(MIN(MA(C,5),MA(C,10)),MIN(MA(C,20),MA(C,30)));

X2:=MIN(X1,MA(C,40));

X3:=MAX(MAX(MA(C,5),MA(C,10)),MAX(MA(C,20),MA(C,30)));

X4:= MAX(X3,MA(C,40));

X5:=1000*(X4/X2-1)<=N;

//偏离值N=30 2%<=N<=5%; 量比M=50 1<=M<=8

均线粘合突破:=MA(C,5)>REF(MA(C,5),1) AND X5 AND CROSS(C,X4) AND 10*DYNAINFO(17)>M;

DRAWTEXT(均线粘合突破,压力*1.5,'粘合突破'),colorgreen;

//均线粘合向上发散主图和选股指标 主图指标

EMA5:=EMA(C,5),colorwhite;

EMA13:=EMA(C,13),coloryellow;

EMA34:=EMA(C,34),colormagenta;

EMA55:=EMA(C,55),colorgreen;

//LL:=EMA55;

LL:=MAX(MAX(EMA5,EMA13),MAX(EMA34,EMA55));

少头排列:=(EMA5<=EMA13 AND EMA13<=EMA34 AND EMA34<=EMA55);

多头排列:=(EMA5>=EMA13 AND EMA13>=EMA34 AND EMA34>=EMA55);

A1:=1000*EMA5/EMA55<=1015 AND 1000*EMA5/EMA55>=975;

A2:=1000*EMA13/EMA55<=1020 AND 1000*EMA13/EMA55>=980;

A3:=1000*EMA34/EMA55<=1015 AND 1000*EMA34/EMA55>=985;

A4:=A1 AND A2 AND A3 AND CROSS(EMA5,EMA13);

A5:=A1 AND A2 AND A3 AND CROSS(EMA5,EMA34);

//粘合

A1:=A4 OR A5;

DRAWTEXT(A1,LL*1.01,'粘'),coloryellow;

DRAWTEXT(A1 AND (少头排列 OR REF(少头排列,1)),LL*1.01,'粘'),colormagenta;

DRAWTEXT(A1 AND 多头排列,LL*1.01,'粘'),colorred;

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

A1:=COUNT(CROSS(MA10,MA20),2)=1;

A2:=COUNT(CROSS(MA5,MA20),2)=1;

A3:= MA5>=REF(MA5,1);

N:=A1 AND A2 AND A3;

DRAWTEXT(N,LL*1.03,'金蜘蛛'),color00aaff;

DRAWTEXT(N AND (少头排列 OR REF(少头排列,1)),LL*1.03,'金蜘蛛'),colormagenta;

DRAWTEXT(N AND 多头排列,LL*1.03,'金蜘蛛'),colorred;

//主升浪8V2-结合均线金叉找买点

//解读一下3个副图指标的用途

//1.指标能反应出强势股的特征,结合均线金叉原理找买进点(日线均线参数10-30-60-120-250-500).在操作中要用指标的起点,不要用在发现指标的尾段。

//2.避免了在长期均线(日线120-250-500)压制下的股票操作。

//3.3个副图指标要一起用,用在找股票是很好的,发现启动点后,实际操作用30-60分钟波段指标,更为准确。

//4.用这3个指标可以查一下你手上操作股票,就能知道是强势还是弱势股票。

//还可以关注现在,在横向运行的股票何时发出强势的信号。

Var1A:=EMA(CLOSE,5)*0.900*100;

Var2A:=VOL/CAPITAL*100;

Var3A:=Var1A-Var2A;

Var4A:=Var3A<1;

Var5A:=Var3A>=1 AND Var3A<5;

Var6A:=Var3A>=5 AND Var3A<10;

Var7A:=Var3A>=10 AND Var3A<25;

Var8A:=Var3A>=25;

极弱股:=IF(Var4A, (-10), 0),COLORff3399, STICK;

弱势股:=IF(Var5A, (-5), 0),coloryellow, STICK;

转型股:=IF(Var6A, 5, 0),COLOR0066FF, STICK;

强势股:=IF(Var7A, 10, 0),colorgreen, STICK;

主升浪:=IF(Var8A, 15, 0),colorffff00, STICK;

//{中期见顶原码 }

庄筹:EMA(WINNER(C)*70,5),colorwhite,NODRAW;

散筹:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5),colorgreen,NODRAW;

Var1:=EMA(EMA(CLOSE,13),13);

控盘:=(Var1-REF(Var1,1))/REF(Var1,1)*1000;

Var2:=100*WINNER(CLOSE*0.95);

高控:=Var2>50 AND COST(85)<CLOSE AND 控盘>0;

N:=高控 AND REF(NOT(高控),1);

DRAWTEXT(N AND 多头排列,LL*1.05,'高控'),colormagenta;



 

  • 微信赞赏

    微信扫一扫,发红包:1-10元
    赞赏时请留言:您的QQ号,让我们记住您的支持
    支付宝赞赏

    支付宝扫一扫,转账支付:1-10元
    付款时填加备注:您的QQ号,让我们记住您的支持!
  • 喜欢就点击上面的赞赏按钮,给小编更新的动力!
    赞赏5元以上,免费远程安装公式

股友评价