公式指标
公式指标

同花顺右侧登峰主图指标公式

分类:同花顺公式 来源:股票资源网 关注:1597 时间:2017-7-26 

MA1000:=MA(C,1000),color556699;

MA500:=MA(C,500),colorwhite;

MA250:=MA(C,250),coloryellow,DOTLINE;

MA120:=MA(C,120),colorgreen,DOTLINE;

MA5:MA(CLOSE,5),colorwhite;

MA10:MA(CLOSE,10),coloryellow;

MA18:MA(CLOSE,18),colorlired,linethick1;

生命线:MA(CLOSE,30),colorliblue,linethick3;

MA55:=MA(CLOSE,55),colorblue;

大30度且34日线:=ATAN((MA(C,34)/REF(MA(C,34),1)-1)*100)*180/3.14159>=30;

大45度且34日线:=ATAN((MA(C,34)/REF(MA(C,34),1)-1)*100)*180/3.14159>=45;

大20度且13日线:=ATAN((MA(C,13)/REF(MA(C,13),1)-1)*100)*180/3.14159>=30;

m34:IF(大45度且34日线,生命线,DRAWNULL),colorwhite,linethick3;

大牛熊分界线:IF(C<=MA1000,MA1000,DRAWNULL),coloryellow,linethick2;

小牛熊分界线:IF(C<=MA500,MA500,DRAWNULL),coloryellow,linethick1;

m250:IF(C<=MA250,MA250,DRAWNULL),colorgreen,linethick1;

m120:IF(C<=MA120,MA120,DRAWNULL),colorgreen,linethick1;

m55:IF(C<=MA55,MA55,DRAWNULL),colorgreen,linethick1;

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;

RSI金叉:=CROSS(RSI1,RSI2) OR RSI1=RSI2;

RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

a=SMA(RSV,3,1);

b=SMA(a,3,1);

e=3*a-2*b;

IF(a<0) a=0;

IF(a>100) a=100;

IF(b<0) b=0;

IF(b>100) b=100;

IF(e<0) ;

IF(e>100);

K:=a;

D:=b;

J:=e;

KDJ金叉:=CROSS(j,k) OR j=k;

DIFF : =EMA(CLOSE,12) - EMA(CLOSE,26);

DEA : =EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

MACD范围:=(MACD>=0) AND MACD>=REF(MACD,1);

均量线5:=MA(VOL,5);

均量线10:=MA(VOL,10);

军量线金叉:=CROSS(均量线5,均量线10);

macd金叉=CROSS(diff,dea);

均量线macd金叉:=(军量线金叉 AND macd金叉);

均量线rsi金叉:=(军量线金叉 AND RSI金叉);

均量线kdj金叉:=(军量线金叉 AND kdj金叉);

macdkdj金叉:=(macd金叉 AND kdj金叉);

k线变色条件1:=(( KDJ金叉 AND MACD范围) OR macdkdj金叉);

十三日日均线下变绿色:=MA(C,13);

diff大于45度角:=ATAN((DIFF/REF(DIFF,1)-1)*100)*180/3.14159>60;

STICKLINE(C/REF(C,1)>1.0925 AND C=H,CLOSE,OPEN,10,0),colormagenta;

STICKLINE(k线变色条件1,OPEN,CLOSE,10,0),coloryellow;

m5:=EMA(C,5),coloryellow;

m10:=EMA(C,10);

m20:=EMA(C,20);

v1:=C>m5 AND m5>m10 AND m10>m20 AND C>REF(C,1) AND m5>REF(m5,1)

AND m10>REF(m10,1) AND m20>REF(m20,1) AND C/O>1.03 AND (H-C)/C<0.02;

大50度且5日线:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14159>50;

大60度且3日线:=ATAN((MA(C,3)/REF(MA(C,3),1)-1)*100)*180/3.14159>60;

大45度且10日线:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14159>30;

操盘线26:=MA(CLOSE,26),colorliblue,linethick3;

k线变色条件5:=大60度且3日线 AND 大50度且5日线 AND 大45度且10日线 AND V1 ;

STICKLINE(k线变色条件5,OPEN,CLOSE,10,0),colorred;

股价金叉13日线变色:=CROSS(C,MA(C,13) );

STICKLINE(股价金叉13日线变色,OPEN,CLOSE,10,0),coloryellow;

十三日日均线下变绿色:=MA(C,13);

STICKLINE(C<MA(C,13),OPEN,CLOSE,8,0),colorligreen;

C3:=REF(C,1);

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,10,0),colorblue;



 

  • 微信赞赏

    微信扫一扫,发红包:1-10元
    赞赏时请留言:您的QQ号,让我们记住您的支持
    支付宝赞赏

    支付宝扫一扫,转账支付:1-10元
    付款时填加备注:您的QQ号,让我们记住您的支持!
  • 喜欢就点击上面的赞赏按钮,给小编更新的动力!
    赞赏5元以上,免费远程安装公式

股友评价