股票教程网

大智慧六指金叉指标公式

Class:大智慧公式 Time:2017-8-7 Hits:779

股票教程网,http://www.91goo.com,友情提供

input:N1(3,1,100),N2(5,1,100),N3(9,1,100),N4(13,1,100);

DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);

DEA:=EMA(DIFF,N2);

DRAWICON(DIFF>DEA,1,12),ALIGN1;

DRAWICON(DIFF<DEA,1,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,1,' MACD'),COLORFFFFFF;

A1:=DIFF>REF(DIFF,1);

RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;

K:=SMA(RSV1,N1,1);

D:=SMA(K,N1,1);

DRAWICON(K>REF(K,1),2,12),ALIGN1;

DRAWICON(K<REF(K,1),2,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,2,' KDJ'),COLORFFFFFF;

A2:=K>REF(K,1);

LC:=REF(CLOSE,1);

RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;

RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;

DRAWICON(RSI1>RSI2,3,12),ALIGN1;

DRAWICON(RSI1<RSI2,3,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,3,' RSI'),COLORFFFFFF;

DRAWTEXTABS(5,5,'股票资源网 www.gpzyw.net'),linethick1,COLOR00EEff;

A3:=RSI1>RSI2;

RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;

LWR1:=SMA(RSV,N1,1);

LWR2:=SMA(LWR1,N1,1);

DRAWICON(LWR1>REF(LWR1,1),4,12),ALIGN1;

DRAWICON(LWR1<REF(LWR1,1),4,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,4,' LWR'),COLORFFFFFF;

A4:=LWR1>REF(LWR1,1);

BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;

DRAWICON(CLOSE>BBI,5,12),ALIGN1;

DRAWICON(CLOSE<BBI,5,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,5,' BBI'),COLORFFFFFF;

A5:=CLOSE>BBI;

MTM:=CLOSE-REF(CLOSE,1);

MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);

MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);

DRAWICON(MMS>MMM,6,12),ALIGN1;

DRAWICON(MMS<MMM,6,13),ALIGN1;

DRAWTEXT(BARSTATUS=2,6,' ZLMM'),COLORFFFFFF;

{股票资源网-股票公式网站 www.gpzyw.net}

MACD金叉:DIFF>DEA,COLOR0000FF;

KDJ金叉:K>D,COLORFF00FF;

RSI金叉:RSI1>RSI2,COLORFFFFFF;

LWR金叉:LWR1>LWR2,COLOR0000FF;

BBI金叉:CLOSE>BBI,COLOR00FFFF;

MMS金叉:MMS>MMM,COLOR00FF00;

MACD金叉 AND KDJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉,COLORRED,LINETHICK2;

六指全红:LAST(MACD金叉 AND KDJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉),COLORRED,LINETHICK0;


股票教程网所有股票公式,仅供学习研究,只有参考价值,请勿以此为依据进行股票交易!

本站所有公式全部免费,如果这条公式对您有价值,或有帮助,请打开微信,扫一扫下面的二维码,赞助本站,金额随意!

感谢您对支持我们的发展和对我们工作的肯定!小编在些表示感谢!

本站提供通达信选股公式,看盘主图副图指标,编写,修改,DLL加密等业务,详询客服!